Sigma MC-11 Adapter: Unfortunately Disappointed

As it currently stands, with room for only one adapter in my camera bag, I’d take the Metabones over the Sigma MC-11 without hesitation

Update #2: I received the dock, updated the 18–35 firmware and performance continues to be poor. I’ve tested with the new Sigma 50–100 f1.8 lens as well and the Metabones again performs significantly better. Sigma’s response is that these items are new and hopefully firmware updates will fix it. I can sympathize somewhat with that, but the issues I’m having are not minor bugs, so unless it’s an issue with my specific Sony camera, I feel like they’ve done a disservice to their reputation by releasing a product too early. My biggest confusion is how other’s have reported such a positive experience with the adapter. Either their standard is significantly low, they’re not being honest, they’re ignorant, I’m ignorant, or I’ve got a bad adapter. As it currently stands, with room for only one adapter in my camera bag, I’d take the Metabones over the Sigma MC-11 without hesitation. While the Sigma offers eye lock, face detect, AF in video mode, auto punch-in on manual focus and other Sony-specific features, the overall AF performance of the Metabones is substantially superior.

 

Screen Shot 2016-05-03 at 6.19.30 AM

Update #1: Within half an hour of contacting Sigma support, I received a response informing me that the issue is likely with the 18–35 f1.8 having outdated firmware. Unfortunately, the MC-11 does not allow for updating the firmware of the lens, only the firmware of the MC-11 itself. The MC-11 update, incidentally, is not intuitive to find on Sigma’s website. Click here for a page where you can download the SOP software (you might have to scroll through a glitchy site for the OSX or Windows option). Plug your MC-11 in and, as of now, enjoy the comfort of knowing you’re on the latest 1.00 firmware. My dock should arrive Friday and I’ll update this post. My hopes are high as this could explain why others had such a positive experience with the adapter.

Screen Shot 2016-04-27 at 11.29.45 AM

Screen Shot 2016-04-27 at 10.51.16 AM

 

I, like so many others, had high hopes for this adapter. Perhaps it was those lofty expectations that leave me so disillusioned. I’m looking for a firmware update to resolve things, but if it doesn’t get any better I might end up sending this back.

There are some things, not specifically advertised by Sigma, that I can’t fault them for (read: Canon brand lens support), but other features specifically advertised simply don’t work well. My biggest issue is that the thing doesn’t even work usably with the Sigma 18–35 f1.8. With the camera in AF-S, the lens frequently and randomly goes completely out of focus without any action on the user’s part. This is totally unacceptable as most photographers are not going to want the focus thrown completely off on a whim by the adapter. Phase detect AF seems slower generally, especially in low light, and even more so in video mode where from my brief testing it looks to be unusable. With the sensitivity and focus speed both on high, the video AF is too slow to be usable for a good portion of the shots I’d need it for. With Sony already a bit behind Canon’s dual pixel, the additional lag imposed by this adapter makes video AF unusable for all but the least-demanding shots. Eye-AF is enabled but doesn’t seem to work nearly as reliably as with Sony lenses. Sony’s mirrorless cameras already feel like lagging Windows ME computers sometimes–boot times are erratic and changing modes sometimes takes painfully too long. It seems like this adapter only aggravates the problem. I feel like too much of the testing of this lens has been to verify that the Sony on-camera menu shows the feature as available now (no “Not supported with this lens” warning) but even though it doesn’t throw an error, the feature isn’t usable. Put a Sony lens on after using the MC-11 and 18–35 combo and you’ll realize a massive difference. Just like the rest of you I don’t want to spend money on Sony’s pricey, focus by wire, lenses, and Canon seems to have long abandoned us, but I feel like most people are better off spending a bit more on Metabones.

_JJF4060

Other grievances include: No 1/4 20 thread on the bottom for mounting (Metabones has it). This becomes crucial with lenses like Sigma’s 18–35 f1.8 which puts all the camera’s weight at the front. Using the camera’s quarter inch mount as the fulcrum makes for an excruciatingly front heavy lens and say goodbye to getting that balance on a gimbal. The inability to accept Canon EF-S lenses is another big one. While it’s not fair to criticize Sigma for lack of support on something they never claimed to support, lots of positive info from the web is trickling in on Canon (rather than solely Sigma Canon mount) lens compatibility. The fact that you can’t even put an EF-S lens on the thing (at least not the Canon 10–18) is discouraging. I truly hope firmware fixes are in the works for this, or available now, as I’ve seen more positive comments from other reviewers. I will keep hunting. I sold my a7rii so I’m wondering if these issues are more exclusive to the a6300.

I’m finding the Metabones to be much more reliable and a much better thought out adapter so far, as the Sony-specific feature set enabled by this adapter does not perform reliably.

When I went online to Sigma’s site in search of a firmware update I saw an option to review. I have done so in hopes that Sigma will address some of these issues. My review is currently pending moderation by Sigma so we’ll see if they’re honest enough to let it through.

Screen Shot 2016-04-27 at 9.35.17 AM

Scroll to Top